Пользовательские сущности
Вкладка Пользовательские сущности позволяет создавать новую сущность, если нужная не была найдена в списке Стандартных сущностей.
Для создания новой сущности нажмите кнопку с изображением плюса. По желанию введите имя сущности. В поле справа введите правило XPDL для новой сущности.
С помощью соответствующих кнопок в верхнем левом углу вкладки созданные сущности можно группировать по папкам, удалять, копировать, перемещать, настраивать.
Кнопка Настройки… в верхнем левом углу позволяет открыть диалоговое окно для настройки сущности (XPDL правила, фильтрация, постобработка, разрешение конфликтов и т.д.). Кнопка станет активной только после того, как вы выберите тип сущности в списке. Для получения подробной информации см. вкладки Фильтры, Постобработка, Разрешение конфликтов и Общие.
Поле Исходный текст содержит первый документ набора данных, с которым вы работаете в данный момент. Текст может быть показан тремя различными способами, например, в том виде, в каком он приведен в исходном наборе данных (см. выше).
Нажмите кнопку Тегированный текст, чтобы увидеть размеченный текст.
В данном режиме каждому слову добавляется тег с указанием морфологической категории слова.
Нажмите кнопку Фрагментированный, чтобы увидеть текст, разделенный на именные группы.
Для получения дополнительной информации см. данный раздел.
В Исходном тексте тестовой панели можно включить проверку текстов на соответствие регулярным выражениям, для этого воспользуйтесь кнопкой Поиск и в появившемся поле введите правило, затем нажмите Enter. Для навигации по записям используйте соответствующие кнопки.
В нижней части вкладки редактора правил также расположена Тестовая панель для проверки нового правила. Пользователи могут указать номер записи (в пределах указанного общего количества) в специальном окне под полем Исходный текст, после чего нажать на кнопку Выполнить проверку (синего цвета) для проведения соответствующей процедуры. В поле Результаты будут отображены сущности, которые извлечет данное правило в ходе выполнения узла:
При клике на результат в таблице (справа), строка в теле правила (наверху) может быть подсвечена. Для этого необходимо нажать на кнопку Показывать подсказки.
Для того, чтобы добавить дополнительные колонки с информацией в результат выполнения правила или, наоборот, убрать из результата, воспользуйтесь настройкой Управление колонками.
Если вы работаете с несколькими правилами, вы можете протестировать каждое правило отдельно. Для этого выделите правило, удерживая левую кнопку мыши, и нажмите кнопку Запустить проверку текущего правила (зеленого цвета). В соответствующем поле будет отображено название правила и его результаты.
Если поле Результаты остается пустым, это может означать, что в выбранной записи искомые сущности отсутствуют, или правило не извлекло никаких сущностей. Попробуйте выбрать другую запись и снова нажать на кнопку проверки текущего правила.
Данная опция позволяет пользователям оценить качество правила и при необходимости корректировать его, не выходя из окна редактора и окна настройки узла еще до его выполнения.
При настройке сущностей нет необходимости отдельно сохранять изменения на каждой вкладке: изменения сохраняются автоматически при переходе с одной вкладки на другую. Если вы попытаетесь закрыть окно настроек сущности без сохранения внесенных изменений (с помощью кнопки ОК), система напомнит вам об изменении настроек и спросит, нужно ли их сохранить.
Вместо того, чтобы вводить номер в поле Запись в таблице, для перехода к нужной записи/документу воспользуйтесь кнопками со стрелками для перехода к самой первой/предыдущей/следующей/следующей результативной/самой последней записи или документу. В этой же строке указывается текущий режим тестирования (По умолчанию). Для смены режима тестирования нажмите правой кнопкой мыши на активный режим.
Вы можете импортировать/экспортировать пользовательские сущность включая настройки постобработки сущности и опции разрешения конфликтов. Для этого используйте соответствующие кнопки на панели инструментов.
Нажмите на кнопку Настройки для вызова окна Настройки теста
На вкладке Настройки теста можно задать режим тестирования:
-
По умолчанию
-
Упрощенная проверка
-
Отладка
Следующие опции доступны и настраиваются только для режима тестирования По умолчанию:
-
Применить фильтры – опция включена по умолчанию. У каждой сущности имеются SRL-фильтры (см. вкладку Фильтры), которые обрабатывают найденные XPDL правилом сущности. Если отключить данную опцию, фильтры использоваться не будут.
-
Использовать постобработчик – опция включена по умолчанию. Если отключить данную опцию, выбранные постобработчики (см. вкладку Постобработка) использоваться не будут.
-
Выполнить разрешение конфликтов между сущностями – см. раздел Разрешение конфликтов.
-
Выполнить разрешение конфликтов между правилами – опция включена по умолчанию. См. раздел Разрешение конфликтов.
-
Создать колонку с именем сработавшего правила – опция включена по умолчанию. В получившемся массиве данных появится дополнительная колонка с именем сработавшего правила.
-
Создать колонку(и) для соответствий – опция включена по умолчанию. В получившемся массиве данных появится дополнительная колонка, которая будет включать сущность в том виде, в котором она встречается в тексте. Если у одной сущности имеется несколько вариантов написания, в получившийся массив данных будут включены все варианты.
На вкладке Опции показа задайте параметры просмотра выбранных режимов тестирования:
-
для того чтобы идентифицировать и анализировать выбранные элементы текста, включите опцию Подсвечивать части документа для выделения определённых текстовых единиц, таких как токены, предложения или абзацы.
-
для режимов просмотра Режим тегирования и Фрагментированный режим отметьте галочками, какие характеристики и параметры морфологического и синтаксического анализа будут отображаться для каждой текстовой единицы.